CLASS-X
INFORMATION TECHNOLOGY NOTES
(UNIT-4 SPREADSHEET)

Session-1

Autosum automatically selects the values around the cells either horizontally or vertically. Autosum is used for
adding the values given in cells automatically without writing the formula to
perform the operation.

Session-2

Conditional formatting allows you to change the formatting (font color, border, shading) of the cells based on
the values in it. You specify a condition for the values in the cell, and if the condition is satisfied then
automatically the formatting of the cell changes.

Following formats can be controlled

* Number format

* Font, font style, and font colour (but not font size)

* Fill colour and fill pattern

* Border colour and border style (but not border thickness)

Steps-
1. Click on Conditional Formatting option available under Styles group in the Home tab.
2. A drop down list appears. Click on Highlight Cells Rules option, a submenu appears.

Session-3

Hide/Unhide
A very handy feature of a spreadsheet is the ability to hide a row/column that is not to be shown to the end
user. The data in hidden row/column is available for calculations though not visible.

Freeze /Unfreeze

Freezing rows and columns is another helpful feature in a spreadsheet. When you are dealing with a huge
amount of data that spans several rows or columns, you may want the headers to remain constant (frozen)
while you scroll through the data so that you can see the identifying names of the rows/columns.

To freeze the rows or columns do the following.
o Open a new spread sheet.
¢ In order to freeze rows or columns click on Freeze Panes option available under Window group in
View tab.
e A drop down list appears as shown below.
e Click on Freeze Panes. Doing so will freeze all the rows above and all the columns to the left of the
selected cell. Scroll your mouse in the spreadsheet the frozen rows and columns remain constant.

Freeze Panes

Keep rows and columns visible while the rest of
the worksheet saolls fbased on current selection).
Freeze Top Row

Keep the top row visible while scrolling through
the rest of the worksheaet

Freeze First Column

Keep the first column visible while saolling
through the rest of the worksheet

Figure 15



Session-4

Page Break-
To print a worksheet with the exact number of pages that you want, you can adjust the page breaks in the
worksheet before printing it. This feature is very useful especially when printing huge sheets.

Open a new spread sheet and create the sheet. On the View tab, in the Workbook Views group, click Page
Break Preview.
Now to set the page break do the following.

* To insert a vertical page break, select the column where you want to insert the page break.
To insert a horizontal page break, select the row to the right of where you want to insert the page break.

* To move a page break, simply drag the page break to the desired location.

Note: You can also remove the page breaks by clicking the Remove Page Break option in Breaks drop down
list.

To return to Normal view after you finish working with the page breaks, click Normal in the

Workbook Views group under the View tab.

Session-5

Page Layout

Spread sheet software provides various page layout options for organizing pages using the Page Layout
option.

To set the page layout options, do the following:

* Click on Page Layout option under Workbook Views group on View tab..
You can set these features -

» Margins (Left, Right, Top, Down)

* Orientation (Portrait or Landscape)

* Page headers and footers

* Hide or display grid lines

* Size of the page

* Define the print area (Set Print Area, Clear Print Area)

* Specify the background

Session-6

MANAGE WORKBOOK VIEWS

Spread sheet offers the users with variable views for the purpose of viewing the outcome of the sheet while
printing.

There are five types of views available in the spreadsheet.

* Normal

* Page Layout

» Page Break Preview

* Custom Views

* Full Screen

Normal View: The default view of the spreadsheet application is the Normal. It's a collection of cells arranged
in the work area.

Page Layout: You can select the Page Layout view in order to quickly fine tune a worksheet that contains
many charts or huge amounts of data and achieve professional looking results.

Page Break Preview: This option is similar to the Page Layout option except you can set the area that is to be
set as a page after inserting page break.

Custom Views: If you would like to view selected areas of a document, you can use the custom view option.
For example, if you would like to point out certain row and column, you can add that to the Custom view.



Full Screen: Selecting this option makes the workbook cover the entire screen. All tabs are hidden from view.
To get back the tabs, click on File> Restore.

Session-7

APPLY CELL AND RANGE NAMES

You can assign names to cells in a worksheet and use it for quickly locating specific cells by entering the
names. This could be useful when working with large spread sheets. For example, if you have a lengthy list of
groceries and prices, you can use names to quickly locate and find total pricing of fruits from the entire list.

Select the cost against the cells that have Apple, Banana, Cherry, Grape, Guava, Mango, Pineapple values
(Keep the Ctrl key pressed and click on the cells — you will be able to select selective cells together!).

Right click and select Name a Range.... Alternatively, you can select Define Name under Defines Names
group in the Formulas tab.

* A New Name dialog box appears prompting to enter a name. Enter Fruits in the Name field and click OK
(figure below).
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Figure 26

If you would like to calculate the total cost of fruits from the list,
* Select an empty cell
* Type Total Cost of Fruits and in the adjacent cell, Type =SUM (Fruits) and press Enter.

Session-8

CREATE MODIFY AND FORMAT CHARTS

A chart is a graphical representation of data, in which the data is represented by symbols, such as bars in a
bar chart, lines in a line chart, or slices in a pie chart. A chart can represent tabular numeric data, functions or
some kinds of qualitative structures.

A Spread sheet enables you to create, modify and format charts based on the data given in the spread sheet.

Chart has many elements; however, only some of the elements are displayed by default. Following
is an description of the elements used in the above chart:
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1. Chart Area of the Chart

2. Plot Area of the Chart

3. Data Points that are plotted in the chart

4. Horizontal and Vertical Axis in the chart

5. Legend of the chart

6. Chart and Axis Title used in the chart

7. Data Label for identifying details of data point in the chart
Chart Types:

Choosing the right type of chart is very important. Different charts display data in very different ways. Using the
best chart type and format helps you to display data visually in the most meaningful way.

Bar charts: A bar chart (horizontal bars) emphasizes the comparison between items at a fixed period of time.
This chart type also includes cylinder, cone, and pyramid subtypes.

Column charts: A column chart, unlike a bar chart to which it is often compared, emphasizes variation over a
period of time. This chart type also includes cylinder, cone, and pyramid subtypes

Line charts: A line chart shows the relationship of the changes in the data over a period of time.

Pie charts: Pie charts contain just one chart data series. A pie chart shows the relationship of the parts to the
whole.

Area charts: An area chart shows the relative importance of values over time.

XY (Scatter) charts: Scatter charts are useful for showing a correlation among the data points that may not be
easy to see from data alone.

Session-9

SORT AND FILTER DATA

Sort is a feature that helps you arrange the selected data either in an ascending or descending order.

Open a new spreadsheet and enter the following data:



A B C D E . f
1 Region  Sales 2008 Sales 2009 Sales 2010 Sales 2011

2 New Delhi 56 67 85 87
3 Mumbai 66 n M 51
4 Caleutta B 65 a 63
5 Chennal !} 85 67 a
6

Now to sort or filter the data do the following:

* Select the data to be sorted and then click on Sort option under Sort & Filter group in the
Data tab. A dialog box appears as shown below.
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* You need to specify on what basis you are going to sort the data in the Sort by field and
select the order that is ascending and descending and then click OK. For example, if you
wanted to sort the data in Sales 2008, you would select the relevant detail in the Sort by list
and click OK. The spreadsheet would be displayed as shown below. You can notice that the
data has been sorted as per the data in 2008 and also that values in the Sales 2008 field are
arranged in ascending order that is from smallest to largest.

1 Region  Sales 2008 Sales 2009 Sales 2010 Sales 2011
2 |New Delhi 56 67 85 &7
3 [Mumbai 66 i =] 91
4 (Chennai ™ 85 67 LE|

‘ 5 |Calcutta 75 65 a7 &3
6

Filter is a feature used for extracting particular data using some conditions. Spread sheet offers both these
features for sorting and filtering data in the spreadsheet.

To filter data, do the following:

* Click the Filter option available under Sort & Filter group in the Data tab. Before applying a
filter you have to select the data along with the header as shown below.



Once you click on filter, the headers will be displayed with a down arrow as shown below.
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1 [Region |»|Sales 20|~ |Sales 20| * |Sales 20| » | Salas 20 *
2 |New Delhi 56 67 85
3 |[Mumbai 66 7 -3 a1
4 [Chennai 74 85 67
5 |Calcutta 75 65 47 63

If you want to filter data that is greater than 75 in the Sales 2009 do the following.

* Click the down arrow available under Sales 2009 header, a dropdown list appears as shown
below.
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Figure 38



Session- 10:

Now to calculate the data across worksheets do the following.

. Go to sheet 2, name it year 2 sheet, and insert the same data in the Sheet 2 for the next
year.

. Go to sheet 2, name it Totals, and insert the same labels.

. Type the sum formula in cell B2, =sum({ , while the parenthesis is opened go to year 1 sheet
and go to year 2 sheet and press Enter. Repeat the same step to calculate sum for other
expenses. Note the way the range is specified (sheetnamelcellnumber).

| A L B | C D . E . F | G | H
Name Janua February March April May June
House Rent I:SuM[‘rearl!Blwearll&:!}
Electric Bill | SUMinumberl, [numberZ], ...) }

Grocery Expenses
Travelling Expenses
Phone/Mobile Phone

w (U WA

Figure 42

To answer the question raised earlier, you could create a new sheet, called Quarter Summary.
To find the average, enter the following formula in one of the cells in the Summary sheet:
=AVERAGE(Reqgion01: Region06IH15)

Spreadsheet calculates the average for all values stored in H15 on all sheets in the range
Region01:Region0&6. If you move the Region06 sheet between Regionl4 and Region05,
the software will adjust the calculation to include the sheets far Regions01, 02, 03, 04, and
06; Region05 will be omitted. Similarly, if you delete or add a sheet anywhere between
Region01 and Region06, the software will include all the sheets located within the range in

Session-11

USING MULTIPLE WORKBOOKS AND LINKING CELLS

Spreadsheet also allows you to link the cells from various worksheets and from various spread sheets to
summarize data from several sources.

In this manner, you can create formulas that span different sources and make calculations using a combination
of local and linked information.

You can link data from other spreadsheets and keep the information up to date without editing multiple
locations every time the data changes. For example, you can display data from multiple departments for an
overview of details without sharing information between sources.
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Figure 45



Session-12

SHARING WORKSHEET DATA

Spreadsheet software allows the user to share the workbook and place it in the network location where several
users can access it simultaneously.

Now to share the spreadsheet do the following.

* Click on Share workbook option under Changes group in the Review tab.
* A dialog box appears as shown below.

21
[E55]| advanced |
I aflow changes by more than one user ot the same time. This
8lso allows workbook merging.
1ho has this workbook cpen now:
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Check the option Allow changes by more than one user at the same time. This also
allows workbook merging.
* Click OK.



